AppV 5 Excel Automation RunVirtual

Answered
0
0

Hi Kae,

I used the informtion from: https://www.alkanesolutions.co.uk/2020/01/10/app-v-5-with-excel-automation-addins-and-runvirtual/

But when using the PublishPackage and UnPublishPackage userscripts as described in the example, the OPEN keys will be created outside the bubble and therefore will not work. Do you have a solution for that?

I found out that when I executed the script at StartVE and RUnInVirtualEnvironment=true then the plugin is loaded.

 

  • Kae
    Hi.  I’m not sure why it wouldn’t work if you are using runvirtual.  If you are not using runvirtual and the addin contains dependencies inside the App-V package then i could see why it would perhaps fail.  It’s also worth checking that your App-V packages aren’t masking the local OPENx registry location too.  Process Monitor should tell you what it can’t find.  Sorry i can’t be of more help – I’m maxed out at the moment!
  • pollewops
    Hi Kae, found the issue. The script is working fine, but another addin called think-cell is causing the issue. Think-cell is part of the connection group and also loaded into RunVirtual. Think-cell is a COM add-in but also created an EXCEL add-in registry key when closing Excel. That OPEN key creating inside the bubble conflicts with the key created outside the bubble. After clicking REPAIR on the connection group, the issue is solved, but I can’t asked that to my users when we change something in the connection group. I need to find a way this automatic think-cell OPEN key creating will be stopped and not happened. I send mail to think-cell for that. But I am sure now this caused the strange bahavior at our configuration.
  • You must to post comments
Good Answer
0
0

Hi Kae, this is solved..it dod see the local registry key and is working now. But I do have anotehr issue detected which i will create a separate forum post for.

  • You must to post comments
0
0

I Kae, thanks for yous answer…good point why the virtual addin does not see the local created OPENx key. Will investigate on my test machine and check if i can find the issue.
thanks

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.